D365 Finance & Operations and Dynamics AX Forum

Expand all | Collapse all

Unable to register a PO Line

  • 1.  Unable to register a PO Line

    SILVER CONTRIBUTOR
    Posted Jul 01, 2019 11:21 AM
    We have a PO with four lines.  All lines are for the same Item Number and same quantities but with different delivery dates.  We were able to register and receive the first three lines.  However the fourth line will not let us do a registration.  For registering we selected the PO line, then drop down 'Update Line', select 'Registration' and complete the registration.  On the fourth line after selecting 'Registration', a form barely displays before disappearing - this occurs very quick but from the window title it appears to be the registration form.  No warning or error is presented.  Additional info - the PO is 'Confirmed' and is in an 'Open order' status.

    We have checked the details of this fourth line to the previous three and they match with the exception of the delivery date which is different on all four lines.

    Can someone shed some light on what the root cause is?  Or where else we can look?

    #AX2012
    #Admin
    #Beginner

    Thank you!

    ​​​​​

    ------------------------------
    Mark Yankovich
    Allegheny Bradford Corporation
    ------------------------------


  • 2.  RE: Unable to register a PO Line

    GOLD CONTRIBUTOR
    Posted Jul 01, 2019 05:48 PM
    Mark,

    Have you tried to delete and re-add the 4th PO line to see if this helps clear out the issue?

    ------------------------------
    Ian Gorman, PMP, MCSE
    Consultant
    ------------------------------



  • 3.  RE: Unable to register a PO Line

    SILVER CONTRIBUTOR
    Posted Jul 02, 2019 07:29 AM
    Edited by Kerstin Newman Jul 02, 2019 07:42 AM
    You might also not be able to register all lines if you don't have enough inventory? Just an assumption, I am not sure if this is actually the case, but it would make sense to me.

    ------------------------------
    Kerstin Newman
    StarTech.com
    London ON
    ------------------------------



  • 4.  RE: Unable to register a PO Line

    SILVER CONTRIBUTOR
    Posted Jul 02, 2019 07:37 AM
    Hi Mark.
    When you say that details are the same, are you sure the transactions are the same.
    Please have a look at the transactions to check  if there are enough qty available. Someone might have cancelled remaining quantity.

    ------------------------------
    Glenn Linaa
    Tasklet Factory Mobile WMS
    aalborg, Denmark
    ------------------------------



  • 5.  RE: Unable to register a PO Line

    Posted Jul 02, 2019 08:44 AM
    Mark,

    Was the Packing Slip posted on the Receipt? Regarding the three registrations, did anyone over receive any of these quantities? My guess without looking in the system would be to see if the delivery remainder went to zero.

    Regards

    -Joe

    ------------------------------
    Joseph Hurylovich
    Owner/Sr. Mfg Consultant
    5702363460
    North Haven PA
    ------------------------------



  • 6.  RE: Unable to register a PO Line

    SILVER CONTRIBUTOR
    Posted Jul 03, 2019 09:57 AM
    Edited by Mark Yankovich Jul 03, 2019 10:15 AM
    Below is a screen shot of the Line Quantity for this PO.  It shows that there is a balance of 20 remaining on the last line.  Nothing was over-received.  Not sure how to tell if a quantity was 'cancelled', but it does not appear to be the case here.  Curious that it is missing Line 3 no matter which form the line details are looked at.  I assume it was 'deleted' when the PO was being created.  Still puzzled as to why we cannot 'register' the last 20 and do not receive any message indicating something is amiss.  Also - to be clear - there are 4 detail lines to record against - the line in question is line #6 (the last line), not four as mentioned in the original message.

    Line Quantity screen shot

    ------------------------------
    Mark Yankovich
    Allegheny Bradford Corporation
    ------------------------------



  • 7.  RE: Unable to register a PO Line

    Posted Jul 03, 2019 01:41 PM
    Hi Mark,

    Do you know of any modifications in your organization environment around this process?  Do you have a developer that can confirm?

    Based on what you outlined, I do not see a reason why the screen would disappear immediately.  If you look at the inventory transactions for the line, do you see 20 'ordered' for this line?  I would likely need to look in the environment myself to diagnose further.

    ------------------------------
    Michael Sigler
    Rangeline Solutions
    ------------------------------



  • 8.  RE: Unable to register a PO Line

    SILVER CONTRIBUTOR
    Posted Jul 04, 2019 02:23 AM
    Hi Mark.
    It looks like a delivery schedule. Line 1 is 80 units. This has been split into 4 deliveries of 20 units.
    Line 6 is the odd one. You have 20 remaining but there are no quantity in the column of either ordered, arrived or registered. That tells me that your transaction is not in balance with the order.
    Please try to run a consistency check on that particular item no. (system admin/periodic/database)
    Remember to use the dialog to limit the run to only this item number in order to save time.


    ------------------------------
    Glenn Linaa
    Tasklet Factory Mobile WMS
    aalborg, Denmark
    ------------------------------



  • 9.  RE: Unable to register a PO Line

    SILVER CONTRIBUTOR
    Posted Jul 05, 2019 09:59 AM
    Edited by Mark Yankovich Jul 05, 2019 11:11 AM
    Appreciate all you responses as they have helped grow knowledge.

    Michael - there have been no modifications made around this process.

    To Glenn's most recent post, I had not noticed "
    20 remaining but there are no quantity in the column of either ordered, arrived or registered".  This line was indeed out of balance.  As a 'work around', this line was removed from the delivery schedule and a new line created.  The registration form now appears as it should.

    A couple of questions...
         - how would the line get 'out of balance' (this seems a data integrity issue)
         - how can this be reproduced in order to prove out this is what caused the registration from to disappear

    Again, thank you.


    ------------------------------
    Mark Yankovich
    Allegheny Bradford Corporation
    ------------------------------



If you've found this thread useful, dive deeper into User Group community content by role