D365 Finance & Operations and Dynamics AX Forum

Expand all | Collapse all

Customer Aging report doesn't execute in batch Dynamics 365 F&O

  • 1.  Customer Aging report doesn't execute in batch Dynamics 365 F&O

    Posted 13 days ago

    We have scheduled to run "Customer aging snapshot" in a batch job every day and is executing with no errors.

    When I go to Collections->Aged Balances, I see that data for some customers is not populated. If I manually run "Update Aging" then it works fine. MS doesn't seem to know the problem and say it will be fixed in future versions. We have had this issue since PU 15 and version 7.0 and we are currently on PU 26 and version 7.0.5257.35417 but still no luck. Does anyone have this issue and have a solution?

    Thank you



    ------------------------------
    Software Developer
    IL
    ------------------------------
    Conference-AXUG_200x200


  • 2.  RE: Customer Aging report doesn't execute in batch Dynamics 365 F&O

    Posted 4 days ago
    Hi, what is your configuration? Do you use customer pools? I've seen this code a while ago and it was different for batch and non-batch processing. The issue I saw was around the way ranging/filtering was done when using customer pools. I would suggest reproducing the issue in a Contoso environment and get it reported to Microsoft again.

    ------------------------------
    Roman Abylkhatov
    IBM
    Armonk NY
    ------------------------------

    Conference-AXUG_200x200


If you've found this thread useful, dive deeper into User Group community content by role