Unified Operations & Dynamics AX Forum

Expand all | Collapse all

Purchase Requisition Error Help!!

  • 1.  Purchase Requisition Error Help!!

    Posted 21 days ago
    Good Morning!
    We are having a problem getting our purchase requisitions to close.  When creating a TCR ( term contract ) or Fast Order ( anything under $5,000) after submitting it goes into review status.  Then we get them approved.  After approving the requisition they should automatically close.  Instead the approval process stops and we receive an error message:

    HAS ANYONE SEEN THIS BEFORE OR DO YOU HAVE ANY SUGGESTIONS?  PLEASE LET ME KNOW!
    THANKS!
    SALLY RICHARDS


    ------------------------------
    Sally Richards
    System Administrator
    Virginia State Lottery
    Richmond VA
    ------------------------------


  • 2.  RE: Purchase Requisition Error Help!!

    GOLD CONTRIBUTOR
    Posted 20 days ago
    Sally, this looks like a security issue. Is it closed by a system user?  I would look at the setup and security (server and AX) for that user.  ​

    ------------------------------
    Shelby Wright
    Applications Manager
    Leatherman Tool Group
    Portland OR
    ------------------------------



  • 3.  RE: Purchase Requisition Error Help!!

    GOLD CONTRIBUTOR
    Posted 20 days ago
    Sally,

    This error is actually a Windows error stating that the user who is running the workflow (or performing that step in the workflow) does not have permissions to log into the machine.

    One guess I might have is that you have a service account performing some task that requires it to log on locally and it doesn't have that permission in AD.

    Unfortunately there isn't one specific thing that could cause this so you may have to kind of step through the workflow and see what process is causing the error.

    Others who have had this error:

    https://social.technet.microsoft.com/Forums/en-US/95ed510e-1a2e-47d5-a0e4-3a411857a46e/logon-failure-the-user-has-not-been-granted-the-requested-logon-type-at-this-computer-win-server?forum=winserver8gen

    https://stackoverflow.com/questions/25477618/the-user-has-not-been-granted-the-requested-logon-type-at-this-machine

    I have managed to fix this myself. You need to go to Start->Administrative Tools->Local Security Policy.

    Navigate to Local Policies->User Rights Assignment->Allow Log On Locally, and add the usernames of the accounts/groups which require access.



    ------------------------------
    Alex Meyer
    Director of Dynamics AX/365 for Finance & Operations Development
    Fastpath
    Des Moines, IA
    ------------------------------



If you've found this thread useful, dive deeper into User Group community content by role