D365 Finance & Operations and Dynamics AX Forum

Expand all | Collapse all

PowerShell AX 2012 R3 Deploy Script

  • 1.  PowerShell AX 2012 R3 Deploy Script

    SILVER CONTRIBUTOR
    Posted 8 days ago
    Edited by Dustin Marker 8 days ago
    Hello,
    We built a PowerShell Deploy Script to bring in our AX 2012 model store from our build environment to our AX 2012 R3 production environment. The PowerShell script is executing from the build server to the production server. We also have the PowerShell script execute the DB sync and the CIL. We tested and executed the deploy script on both our 
    sandbox and stage environments successfully. When we executed the deploy script to our AX 2012 production environment, the deploy script imported the model store and started the AX client on the production AOS server, but it did not initiate the DB sync or the CIL. We have done significant troubleshooting and it appears the AX client starts then it freezes. We allowed it to run for about 90 minutes before we stopped it. We browsed the Windows event logs, but couldn't find anything that looked unusual. The person executing the deploy script has system admin privileges in the AX 2012 production environment. There appears to be something different on our production server than our test servers. We have tried many variations of permission changes with no success.



    Any suggestions?


    ------------------------------
    Dustin Marker
    ------------------------------


  • 2.  RE: PowerShell AX 2012 R3 Deploy Script

    Posted 7 days ago
    Hi Dustin,

    It's odd that it works in other environments and not the production.  If I understand you correctly it's only not doing the DB sync and CIL.
    Have you tried running the command from a PowerShell prompt to ensure that it runs that way.

    Are both your servers running the same OS?  I saw some differences between Windows 2012R2 and Windows 2016.

    Thanks,

    ------------------------------
    Michael Costello
    Senior AX developer & Team lead
    McWane, Inc.
    Athens GA
    ------------------------------



  • 3.  RE: PowerShell AX 2012 R3 Deploy Script

    SILVER CONTRIBUTOR
    Posted 7 days ago
    Edited by Dustin Marker 7 days ago
    The remote execute from the build to the production doesn't work with any command that requires the AX client to open. When we run the command directly on the production server it executes and completes. As soon as we run the command from build to production the AX client appears to freeze.

    Both servers are running the same OS.
    It is a mystery.
    Thank you,

    ------------------------------
    Dustin Marker
    ------------------------------



If you've found this thread useful, dive deeper into User Group community content by role