D365 Finance & Operations and Dynamics AX Forum

 View Only
  • 1.  Local Default Printer Issue through RDP & AX2009

    Posted Mar 12, 2020 10:57 AM
    An outside sales rep with Local Default Printer Issue through RDP & AX2009. AX2009 is not remembering local personal redirected printer. It keeps trying to pull another printer. We deleted all other printers on local desktop. It is still trying to pull a scanner printer on the server as the default. We will set printer in AX2009 and while he is in that session, it will remember it, but as soon as he logs out and back in, it resorts back to scanner printer on server.

    We have blown out all usage data in AX and blown out user profile on the four servers. We have tried using a different computer and different local printer, same issue.

    Other programs DO recongnize the local printer as the default on the RDP.

    Any suggestions?

    Stephanie Elam
    Keystone RV

  • 2.  RE: Local Default Printer Issue through RDP & AX2009

    Posted Mar 13, 2020 11:44 AM
    We are on 2012 R2 and we've had this issue since the beginning. We have tried everything you mentioned, and as you said, some user's default printer will change. Our users are accustomed to checking the printer settings before they print the import stuff like checks.

    Steve Padfield
    IT Manager
    P.W. Gillibrand Co., Inc.
    Simi Valley CA

  • 3.  RE: Local Default Printer Issue through RDP & AX2009

    Posted Mar 16, 2020 01:26 AM
    Hi Stephanie, 
    You might try these methods: 
    1. When open RDP connection, click Local Resources tab, ensure in the Local devices and resources field have the Printers box ticked. 
    2. If above setup does not correct the issue, then ask your IT support to configure the user printing policy when login in RDP server, and force AX to use the default printer. 

    Conrad Deng
    BEC Feed Solutions

  • 4.  RE: Local Default Printer Issue through RDP & AX2009

    Posted Mar 17, 2020 09:30 AM
    If Post #3 above doesn't work, we just encountered this issue here. 

    I spoke with the person who resolved it for our user and they said that when the user logs into RDP it tries to load the local printers on their computer.  She removed the printers set up in the terminal server/RDP session and re-added them as network printers there. 

    She then changed the properties of the RDP connection, clicking the Local Resources tab and UNchecking the Printer box.  This ensures that the RDP connection does not try to load the user's local printers when launching, and uses the network printers set up in the RDP session. 

    I would think that either Post #3 above or this option should solve your issue.

    Mark Jones
    Project Manager
    Fenton MO

If you've found this thread useful, dive deeper into User Group community content by role